Page 1 of 1

IFTT Problem with Connection

Posted: 17. Jul 2020, 06:12
by jdueltgen
When setting up an IFTTT integration, I receive an error in the final step:

"Review and finish
Step 6 of 6
There is a problem with your Connection
Could not create your Connection. Please try again later."

My account profile shows IFTTT connected and I am able to follow all of the steps in IFTTT Action example ( up until the last step. IFTTT service appears to be working normally as I set up some other actions at about the same time. Tried to set up Pushsafer three times and got the same error each time. Any ideas why this isn't working?

Re: IFTT Problem with Connection

Posted: 17. Jul 2020, 10:09
by admin

i got the same error!
I contacted IFTTT, they have to solve the issue!


Re: IFTT Problem with Connection

Posted: 17. Jul 2020, 19:39
by admin
here the answer from IFTTT > i will update the IFTTT Pushsafer service soon and set the field title/message not to private. Currently you can use the work around discribed below!

Sorry about the error messages your users are seeing when creating Applets!
I've tested it a few times with Pushsafer, creating different Applets (thanks for the great service BTW!) and can confirm this is something we already have logged for the team to address.
What is most likely throwing off the Applets your users try to create is the conflict between the Message/Title action fields being set to private and not allowing ingredients as a result, and IFTTT pre-filling these fields with default values that do contain ingredients. These show up as red when you create a new Applet (I tried Email -> Pushsafer and got the ingredients from email pre-fill the message field, which is set to private and cannot include ingredients as a result).
The fix we want to do from our end is disable pre-filling default values into action fields that are private, but there is no firm ETA on it.
Users can work around the issue by not including ingredients into the message/title fields.
It is worth considering if these fields should be set to private in the context of the service. As a new Pushsafer user I'd definitely want to pass data from the trigger to the Pusgsafer action via ingredients.
What are your thoughts on this? Please let me know if my explanation makes sense or if you have any questions.

Re: IFTT Problem with Connection

Posted: 20. Jul 2020, 19:18
by admin
Great news! IFTTT fixed the issue! Now you can add pushsafer as IFTTT action trouble-free.
It tested it by my self.

Regards Kevin