PushSafer iOS app launch behaviour

Pushsafer make it easy and safe to get push-notifications in real time on your Android or Windows mobile device, iPhone, iPad and Desktop!

Mit Pushsafer kann man in Echtzeit, einfach und sicher, Push-Benachrichtigungen auf sein iPhone, iPad, Android oder Windows Gerät sowie auf den Desktop senden lassen!

======================
Google Play
App Store
Windows 10 Store
Homepage
PhillKelley
Posts: 3
Joined: 20. Jul 2019, 05:10

PushSafer iOS app launch behaviour

Postby PhillKelley » 20. Jul 2019, 05:53

I'm new to Pushsafer. I've registered, installed the app on three iOS devices, sent some test messages, had notifications turn up, and so on. All that side of things seems to be working brilliantly.

But I've noticed two oddities when launching the app on my iOS devices (all running iOS 12.3.1). I am using the word "launch" to mean "the app is not running in the background when I tap its icon on the home screen". I will use the word "relaunch" to mean "switching the app which is running in the background to the foreground".

First, if I set "Location Services" to "While Using the App", then each time I launch the app by tapping on it in the home screen, it throws up an alert saying "Pushsafer requires location tracking permission. Would you like to open app settings?" followed by "Cancel" and "OK" buttons.

If I tap "Cancel" then another alert says "Attention: Turn off reminder to access the current location?" along with "Yes" and "No". If I tap "No" then the app sits at the login screen (ie does not auto-login). If I then press the Home button and relaunch the app, it does not re-display the location services alert and automatically logs-in.

If I click "OK", I am taken to "Settings". If I make no changes to the "Location Services" options and instead do nothing other than return to Pushsafer (either by the "back" link at the top, left of the screen, or by pressing the Home button and relaunching Pushsafer), the app does not re-display the location services alert and auto-logs-in.

Fairly obviously, if I either change "Location Services" to "Always" or click "Yes" at the ""Attention: Turn off reminder to access the current location?" then this problem will go away, but I should not have to do that. By definition, at the moment when the "Pushsafer requires location tracking permission" alert is displayed, Pushsafer is running, so "While Using the App" is in force. It seems to me that any internal test for the availability of location services should not be failing. In other words, I think this alert indicates a logic error in the app.

Second, assume that I have changed "Location Services" to "Always" (ie so that the alerts mentioned above do not appear). On launch (remember this means "was not running"), the app always sits at the Registration screen and does not auto-login. If I click the Home button and relaunch (remember this means "was running in the background") then the app completes the auto-login process.

Granted, most of the time when you are actually using the app (instead of just perusing the system's pulldown list of notifications) then it is no big deal to do a launch/relaunch to avoid having to re-enter credentials. But it seems to me that, just like the "location services" issue, this auto-login behavioural difference suggests that the "launch" vs "relaunch" code paths are somehow in conflict.

User avatar
admin
Site Admin
Posts: 562
Joined: 1. Dec 2014, 12:41
Location: Germany

Re: PushSafer iOS app launch behaviour

Postby admin » 22. Jul 2019, 09:15

I do not think that the auto login problem is related to location tracking.

After you cancel the permission question, you got a second popup, when you confirm this, the app dont ask for this permission anymore.

This should help, if not. Please try to reinstall the app!

Please give me a feedback, if this solve the issue or not!

Kevin
Pushsafer DE: Dir gefällt Service und Support! Dann freuen wir uns auf deine Bewertung!
Pushsafer EN: You like Service and Support! Then we look forward to your review!

Pushsafer.com Website - iOS - Android - Windows 10

PhillKelley
Posts: 3
Joined: 20. Jul 2019, 05:10

Re: PushSafer iOS app launch behaviour

Postby PhillKelley » 22. Jan 2020, 00:35

Hi Kevin,

I am very sorry for the long delay in replying. When I made the original post, the UI said the post needed to be approved and that I would be notified when it was approved. No notification ever arrived. Although I checked a couple of times, I could never find my original post so I forgot about it. This is probably all due to me not knowing much about the way this forum works.

To answer your question, it is now solved but I think it was the result of an update to the iOS app rather than anything I did.

What happens now on either launch (app not running state) or re-launch (app already running, brought to the front) is that it displays "Please wait..." then goes to the list of notifications. It never shows the login screen.

For a while (somewhere after I wrote the original forum post but before, say, several months ago) the behaviour on launch was that the app would show me the login screen but if I simply waited it would then clear the login screen by itself and go to the notifications list.

I have Location Services for PushSafer set to "while using the app".

I have never re-installed PushSafer. It has only ever been upgraded in-situ from the App Store.

Again, sorry for being so slow to reply.

Phill

User avatar
admin
Site Admin
Posts: 562
Joined: 1. Dec 2014, 12:41
Location: Germany

Re: PushSafer iOS app launch behaviour

Postby admin » 22. Jan 2020, 10:01

great to hear that all works fine now!

Kevin
Pushsafer DE: Dir gefällt Service und Support! Dann freuen wir uns auf deine Bewertung!
Pushsafer EN: You like Service and Support! Then we look forward to your review!

Pushsafer.com Website - iOS - Android - Windows 10


Who is online

Users browsing this forum: No registered users and 1 guest